マイニング用RX470を買ったけど、Socket FM2のマシンで使えない(回避方法あり


2019/01/19追記:回避方法があることがわかったので、後半に追加しました。


最近話題のマイニング用RX470を、Socket FM2(A10-5800K)の延命に使おうと買いました。

さすがにオンボードのRadeon HD7660Dだと遅かったので、Radeon HD7850を増設してあったので、それをおきかえようと思ったのですが、問題が・・・

まず、電源コネクタの問題。

うちの電源、350Wだったんですが、PCI-Eの6pinはあっても8pinが削られていた。

とはいっても、とりあえず、6pinを指してみたら動きましたけどね。

で・・・Windows10で認識はしたものの、うまくGPUを使った動作をしない・・・

本来省電力がHD7660Dになることが期待されるところなんだけど、両方ともRX470になっている。

ドライバのステータスが「インストールされたドライバーがありません」なんて表示だけど、ディスプレイ出力はちゃんとされている、という謎な状態・・・

じゃぁ、Radeon HD7660Dのドライバをインストールしてみたら、今度はRX470の認識が・・・

どうやら、Radeon HD7660DなどRadeon HDの世代とRX4世代は共存できないようです。

・・・というわけで、しばらくRX470はお蔵入りです。


さて、2019/01/19追記箇所はここから・・・

RX470のブラケットを細工もしくは取り外してHDMIコネクタを挿せるようにする必要がありましたが、回避する方法がありました。

まず、マザーボードのみで起動し、BIOS設定でグラフィックをオンボード優先にして一度起動しておきます。

2回目はRX470を指し、HDMIには何も挿さずに起動し、ドライバをインストールし、再起動し、RX470のドライバがちゃんと組み込まれた状態であることを確認します。

電源を入れたままの状態で、HDMIにダミーもしくはモニタを繋ぎます。そうすると、Windows側でディスプレイ認識されます。

この追加されたモニタの方をプライマリに設定し、画面を複製設定します。

そうすることで、RX470をGPUとして使用しながらもマザーボード上のDVIコネクタからディスプレイ出力させることができました。

6 Replies to “マイニング用RX470を買ったけど、Socket FM2のマシンで使えない(回避方法あり”

  1. 突然のコメント失礼します。
    当方FM2(A10-6700T HD8670D)で大ハマリしていたところ、こちらに辿りつきました。
    大変参考になりました。ありがとうございました。

    1. AMD同士だから大丈夫でしょ!って気軽にやったらこんな問題が出て、えーーーー、って感じですよねぇ^^;;;

  2. 申し訳ないですがお尋ねさせて下さい。当方もFM2+環境です。
    「2回目はRX470を指し、〜RX470のドライバがちゃんと組み込まれた状態である」
    この状態はまだ、(osakana様の)HD7660Dはうまく動作していない(!マークだったりディスプレイがMS互換ドライバだったり)
    という状態にあったでしょうか?

    仮にそうだとしまして、
    「電源を入れたままの状態で、HDMIに~画面を複製設定します」
    複製設定ができる段階まで進むと、ドライバはどうなっているでしょうか?
    Windowsが追加モニタを認識すると両ドライバが正常な状態になるのでしょうか。

    1. なんというか非常に謎な状態で本文中にある「Windows10のSocket AM2環境を久々にオンボード出力に変えたらRadeon HD 7660Dのドライバステータスが不思議な状態になってるな・・・」のツイートについてる画像のような感じで、ツリー上は正常動作ぽいのに、「デバイスの状態」では「このデバイス用にインストールされたドライバはありません」という謎な表示になります。

      1. ありがとうございます。
        色々やってみましたが、うまく行きませんでした。
        ツイートを見たところ、Catalystが入っている上にRX470のドライバを入れている状態ですよね。
        ドライバ排他なので、(ツリー上は正常で)RX470が正常動作している状態は
        マザーの方のドライバがコメント戴いた通りの状態ではあります。
        このままではHDMIを刺してもモニタを認識しませんでした。

        当方はDVIをモニタに繋げて、更に途中で刺すHDMIも同じモニタの
        HDMIコネクタに繋げる手順を踏んでいるので、この辺りが差異なのかもしれないですね。
        もうしばらく粘って、駄目だったら次にPCを組む時まで眠らせておこうと思います。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください