Huawei G6 L22のAndroid OSを4.4.2にバージョンアップする


Huawei G6 L22を使っていたが、Android 4.3なので、ポケモンGoが動かず、Acer Liquid Z330に乗り換えた。

で、あまったG6の活用方法を調べていたところ発見があったので、メモ書きとして残しておく。
(つまりは、実践していない情報なので、やり方を聞かれても知りません)

海外のHuawei G6 L11(LTE対応機)には、Android 4.4.2が出ている
Official kit kat 4.4.2 ROM for HUAWEI ASCEND G6 – L11
Step By Step How to Upgrade G6 – L11 to B370

FirmwareのバージョンがB370になるとAndroid 4.4.2となるようだ。
このB370を元に改造したバージョンもあり、そちらでは、/dataパーテーションの拡張や、ソフトウェアの入れ替えなどが行われているようだ。

公式のB370が日本のG6 L22に、そのまま書けるのか、それとも、boot loader unlock申請が必要なのか、というあたりが不明。
B370改造版のほうの説明に、たぶんG6-L22も大丈夫。DualSIMモデルのG6-L33はちょっと微妙、的な記載があったので、大丈夫な可能性は高いけど、使えなくなる可能性も・・・

日本のG6-L22のfirmwareイメージは発見できなかったが、フィリピン版のG6-L22は下記から入手できる
Huawei G6 Firmware(G6-L22, Android 4.3, EMUI 2.0, V100R001C81B120, Philippines)
どの程度、日本版G6-L22と同じなのかはわからない。
ただ、過去にHuawei以外の端末で日本仕様のAndroid機が、フィリピンで再販されたことがあったので、ハードウェア自体は同じなんだろうな、と考えている。

なお、「Huawei G6 cyganogenmod」で検索すると、非公式Cynanogenmod11が出てくるが、これはLTE非対応のG6-U??モデル用。
LTE対応のG6-L??モデル向けには出ていないと認識している。

HuaweiのAndroid機用のファームウェアアップデート用のパッケージングを再構成するためのツールがあるようだ
[TOOL] Huawei Update Extractor [UPDATED: v0.9.9.3] | OPEN-SOURCE LIBRARY
→「https://github.com/worstenbrood/HuaweiUpdateLibrary


2016/07/28追記

実際に試してみたところ、アップデートファイルが違うといって蹴られました。

oemsbl version list check error!
J, write data error
Error:update.app is a invalid package
Error:SD card update failure, SD card update abort!

メモリ1GBのAcer Liquid Z330でポケモンGoが出来た


丁度発注していたAcer Liquid Z330でポケモンGoが動くか確認してみた・・・

RAM 1GBの機種だけど動くかなぁ?と思っていましたが
ARは無理でしたが、それ以外は問題無く動作しました!

・・・おや?
楽天モバイル取り扱い端末における「Pokémon GO」の動作検証状況について

Liquid Z330 × 非対応

「非対応」って、どういう意味だろ?
公式にはRAM 2GB以上とあるせいかな?(Z330はRAM 1GB)


2016/07/26追記

Z330で「GPSを探しています」というメッセージのままプレイできない、という話があるようです。
が・・・うちでは、そんなことなく遊べています。
動かない人はFirmwareが古いんじゃないですかねぇ

メモリ1GBのCovia FLEAZ F4でポケモンGoが出来た


Covia FLEAZ F4に、ポケモンGoがインストールし、ARが動かない以外は、重いという問題はあるものの、プレイすることができました。

ただ、マーケットアプリで「ポケモンGo」と検索してもでてこず「Pokemon go」と英語で検索したら出てきた、というところが変わった点でしょうか。
ちなみに開発会社の「niantic」で検索しても出てこなかったのは謎です。
Ingressのページから、他のアイテムに表示されてはいるのですけどね・・・

ポケモンGoのGoogle Playストアのリンク「https://play.google.com/store/apps/details?id=com.nianticlabs.pokemongo

初期化状態からインストールする場合の注意点
・初期のPlayストア(ver4.xx)ではインストールできない
 一回Playストアを使ってからしばらく放置しているとアップデートされるのを待つ必要がある
・Google開発者サービスのアップデートも必要とする
 意図的にアップデート画面を出すのが面倒なので、GmailアプリやGoogleマップアプリをインストールし
 アプリを起動しようとすると、開発者サービスの更新を要求されるので
 そこから更新を行うのが簡単でしょう